Installation issue

Feb 28, 2012 at 8:49 AM

Hi,

I  have tried to import the LDGAGUtilities_1_7_0_1_managed.zip solution in both partner hosted and CRM Online environments but I keep getting an error (0x80040256) saying 'the Action failed for assembly 'Crm2011LdgManager, Version=1.7.0.1, Culture=neutral, PublicKeyToken=db57729060e099f3': Assembly must be registered in isolation'. Does this mean you can only use this plugin for on premise implementations? I don't think Microsoft or CRM platform hosting providers allow for plugins to be registered in isolation??

Thanks in advance for your reaction,

Aad

Coordinator
Feb 28, 2012 at 12:07 PM

Hi, CRM Online does not support custom activities yet, but according to Microsoft (http://crmpublish.blob.core.windows.net/docs/ReleasePreviewGuide.pdf) this limitation has been lifted with the Q2 update. When the update is deployed (not sure whether it has already) I'll be looking for people who can test this, so if you are available to try it out that would be greatly appreciated.

Feb 28, 2012 at 12:59 PM

Hi Gemina,

Thanks for the speedy reply, however it seems the error is during the import of the solution, not when I try to use it..? You are mentioning CRM Online but we are using a partner hosted CRM flavour, I thought that was the same as on premise?

Thanks

Aad

 

May 2, 2012 at 2:05 PM

Hi Gemina.

 

I seem to having the same issue as Cubeconsulting.

When I try to import the managed solution , the import fails and the error message that I get is "An error has occurred. Try this action again. If the problem continues, check the MSCRM Community for Solutions......."

I have attempted importing several times with no luck , It fails when it tries to import the Plugin Assembly. 

Using an On-Premise installation.

 

Any ideas ?? 

Thanks

Nick

May 14, 2012 at 2:07 PM
Edited May 14, 2012 at 2:19 PM

I'm getting exactly the same error when installing to an on-premises CRM 2011 deployment (test system first), logged on as system admin.

Really appreciate any help you can give to get this installed.

 

<edit: I have now tried in a separate VM environment and it worked. Differences? VM has only UR6, real test org is UR7 and is using IFD / claims based authentication (should make no difference but thought it was worth mentioning). Hope this helps resolve the issue />

 

Adam